User interface (startup)

Network licence error when using local licence

Problem

A network licence error is shown when opening the Bladed GUI, even though a local dongle is plugged into the machine, and the expected licence features are shown on the Features page on the licence manager website (http://localhost:1947/_int_/features.html).

The specific error message may differ depending on the Bladed version being used, but it may be similar to one of the following:

Network licence error message 1

Network licence error message 2

Cause

The dongle preference setting in the Bladed GUI is currently set to Use network dongle. This results in Bladed ignoring the local dongle plugged into the machine, and attempting to use a network licence instead (which may not be available).

Solution

The problem can usually be resolved by changing the dongle preference setting within the Bladed GUI, using the steps below:

  1. When the error message is shown, click the Cancel button. The Bladed GUI will then open.
  2. In the main Bladed GUI window, open the Tools menu in the menu bar, and select Preferences.... The User Preferences dialog will then open.
  3. The selected option in the dropdown at the bottom of the dialog is likely to currently be Use network dongle. Change the selected option to Use local dongle if possible, and click OK.

    User Preferences dialog, showing "Use local dongle if possible" option being selected

  4. When the dialog closes, the the licence on the local dongle should then be recognised, and the expiry date of the licence (or the fact that it is a perpetual licence) will be stated at the bottom of the main Bladed GUI window. If the licence does not appear to have been recognised, try closing the main Bladed GUI window and restart the application again.

"Terminal services (remote terminal) detected" error

The following error message is shown when trying to open the Bladed user interface on a machine over an remote desktop (RDP) session:

Local licence error: Terminal services (remote terminal) detected (haspStatusTerminalServiceDetected).

Cause

The remote machine is using a standalone licence (i.e. a standalone dongle is plugged into the remote machine). The licensing system does not allow standalone licences to be used on machines which are accessed remotely.

Solution

If you wish to connect remotely to a machine using an RDP session, the remote machine must be hosting a network dongle.


"Could not delete file garrhas2.bak" error

The following error message is shown when trying open the Bladed 4.10 (or earlier) user interface, and the application fails to start:

Could not delete file garrhas2.bak. Check that User Account Controls are switched off

Could not delete file garrhas2.bak error

Cause

This error can occur if the Bladed 4.10 (or earlier) user interface has not been started using administrator rights.

Solution

Right-click on the Bladed shortcut (or bladed_m72.exe file) and choose the Run as administrator option.


"Run-time error ‘91’: Object variable or With block variable not set" error

This error occurs when the user chooses the Retry option after the initial licence check fails on start-up:

Run-time error 91 error message

The issue affects Bladed 4.9 to 4.11, and has been fixed in the following versions:

  • 4.9.0.34
  • 4.10.0.26
  • 4.11.0.16

"Run-time error ‘13’: Type mismatch" error

This error occurs when Bladed 4.3.0.79 (and all earlier versions) request a licence hosted on a NetTime 250+ dongle.

There are two possible workarounds:

  1. Upgrade to Bladed 4.3.0.80 or later.
  2. Use a different dongle type, such as a NetTime 50, or a local dongle. Contact us to discuss making changes to your licences/dongles.

User interface licence log file

The user interface licence log file (HASPUI.LOG) can be generated if the user interface licence is not functioning correctly:

  1. Open an administrator command prompt (type cmd.exe into the Start menu, right-click the app and choose Run as administrator).
  2. Change directory to the Bladed installation folder, e.g. cd /d “C:\DNV\Bladed 4.18”
  3. Run the command: Bladed_m72.exe -log
  4. Reproduce the issue, and close Bladed.
  5. A log with filename HASPUI.LOG will have been written to the Bladed installation folder.

Need help?

If the information above does not help to resolve your problem, please contact us for further assistance.

When contacting us, please provide all relevant details related to the problem, such as:

  • Dongle number (e.g. DT/1234) or Key ID
  • Screenshots of any error messages or other symptoms
  • Steps to reproduce the problem
  • Any relevant log files